Tag Archives: deploying

Deploying an External Content Type, Error: The default web application could not be determined

I had this error today creating an External Content Type for Business Connectivity Services (BCS) in Visual Studio 2010. I had to get help resolving it so I wanted to share the resolution.


Error occurred in deployment step ‘Add Solution’: The default web application could not be determined. Set the SiteUrl property in feature BdcModelProject2_Feature1 to the URL of the desired site and retry activation.


Parameter name: properties


You can resolve this by editing the Feature1.feature file in Visual Studio 2010. Open the template and add a line to tell them what your web application is. Mine is called http://intranet.contoso.com


Add this line:     <Property Key=”SiteUrl” Value=”http://intranet.contoso.com/” />


So the full template now looks like this:


<?xml version=”1.0″ encoding=”utf-8″ ?>
<Feature xmlns=”http://schemas.microsoft.com/sharepoint/“>
  <Properties>
    <Property Key=”GloballyAvailable” Value=”true” />
    <Property Key=”SiteUrl” Value=”http://intranet.contoso.com/” />
  </Properties>
</Feature>


Read More

How do you get Flash to work in Sharepoint 2007?

I was able to get flash to work in Sharepoint 2003. I however am having trouble deploying in Sharepoint 2007. Any tips would be great.

Chosen Answer:

Lots of Luck.
Thats the Great Thing about Early Adopters, they are the Guinea Pigs. Did you try some testing before doing the Install ?
Is this a Live Production Box ?
Sharepoint 2007 is buggy. Call MS Support
by: Mictlan_KISS
on: 20th October 07